MTL2 - Service Interruption
Incident Report for
ThinkOn
Resolved
Services have been restored.
Posted
Feb
09
,
2026
-
17:52
EST
Identified
We are working on resolving the issue.
Posted
Feb
09
,
2026
-
16:34
EST
Update
We are continuing to investigate this issue.
Posted
Feb
09
,
2026
-
14:06
EST
Investigating
We are receiving multiple reports of service issues at the MTL2 site. Our team is actively working to identify the scope and root cause. Updates to follow.
Posted
Feb
09
,
2026
-
13:57
EST
This incident affected: MTL2 (MTL2 Virtual Compute, MTL2 Virtual Compute Backups).
×
Subscribe to Incident
Subscribe to updates for
MTL2 - Service Interruption
via . You'll receive .