[CMH1] Service Disruption with Data Protect 365 portal

Incident Report for ThinkOn

Resolved

The service disruption with the Data protect portal is now resolved.
Posted Mar 17, 2026 - 14:42 EDT

Investigating

We are currently experiencing an issue accessing the Data Protect portal. Our team is actively investigating the problem.
Posted Mar 17, 2026 - 13:07 EDT
This incident affected: CMH1 (CMH1 Veeam M365).