Veeam O365 MEL3 down
Incident Report for
ThinkOn
Resolved
Our engineering team has successfully resolved the issue. If you notice failures after today please reach out to the ThinkOn Service Desk.
Posted
May
31
,
2026
-
08:05
EDT
Update
We are continuing to investigate the issue. ThinkOn engineers are working with the vendor (Veeam support) to resolve the issue.
Posted
May
30
,
2026
-
20:14
EDT
Update
We are continuing to investigate this issue.
Posted
May
29
,
2026
-
23:34
EDT
Investigating
We are currently investigating the issue. ThinkOn engineers are working with the vendor (veeam support) to resolve the issue.
Posted
May
29
,
2026
-
23:31
EDT
This incident affected: MEL3 (MEL3 Veeam M365).
×
Subscribe to Incident
Subscribe to updates for
Veeam O365 MEL3 down
via . You'll receive .