We would like to inform you that the recent power disturbance at our Kamloops Data Centre has been fully resolved. All systems are now stable and operational.
Posted Aug 20, 2025 - 13:01 EDT
Investigating
The DC team is currently investigating the power disturbance at the Data Centre.
Posted Aug 20, 2025 - 11:33 EDT
This incident affected: KLP1 (KLP1 Internet Connectivity, KLP1 Virtual Compute).