Object Storage Inaccessible
Incident Report for
ThinkOn
Resolved
Issue has been resolved. All the OBJECT STORAGE in MEL3 is accessible.
Posted
Dec
01
,
2025
-
00:34
EST
Update
We are continuing to investigate this issue.
Posted
Nov
30
,
2025
-
19:55
EST
Investigating
Object Storage is currently inaccessible.
Posted
Nov
28
,
2025
-
23:45
EST
This incident affected: MEL3 (MEL3 Object Storage).
×
Subscribe to Incident
Subscribe to updates for
Object Storage Inaccessible
via . You'll receive .